Go Back   tbirdforum.com > Thunderbird Model Years > Flair Birds [1964-1966]

Flair Birds [1964-1966] You have a Fourth Generation Bird or just have some questions about them? Then this forum is for you, check it out.

64 thunderbird gauge problem

This is a discussion on 64 thunderbird gauge problem within the Flair Birds [1964-1966] forums, part of the Thunderbird Model Years category; I have a major problem my fuel oil and temperature gauges are not working. I have already replaced the constant ...

Reply
 
LinkBack Thread Tools
  #1 (permalink)   IP: 174.44.74.134
Old 09-12-2010, 10:42 PM
 
Join Date: Sep 2010
Posts: 22
Rep Power: 0
richie3002 is on a distinguished road
Garage
Unhappy 64 thunderbird gauge problem

I have a major problem my fuel oil and temperature gauges are not working. I have already replaced the constant voltage regulator and that didnt fix my problem i havnt realy checked the oil or fuel sending unit so if you guys have any advice it would be much appreciated.
Reply With Quote
  #2 (permalink)   IP: 69.231.141.15
Old 09-13-2010, 12:01 AM
redbird1's Avatar
Los Angeles Ca.
 
Join Date: Feb 2010
Location: Los Angeles
Posts: 92
Rep Power: 14
redbird1 is on a distinguished road
Garage
I suspect the cvr is defective.
If it were maybe one gauge giving you trouble, it would probably be a sending unit, but it is highly unlikely all three sending units would be toast.
Even new units are sometimes defective.
I would advise getting another cvr.
Bob.
__________________
Plan your work, and work your plan
http://public.fotki.com/redmk4convt/
http://www.cardomain.com/id/lincmk4
Reply With Quote
  #3 (permalink)   IP: 174.44.74.134
Old 09-13-2010, 12:34 AM
 
Join Date: Sep 2010
Posts: 22
Rep Power: 0
richie3002 is on a distinguished road
Garage
well i bought the cvr brand new at tbirdnest so i wouldnt think the cvr is the problem is there a way to test the cvr itself
Reply With Quote
  #4 (permalink)   IP: 69.231.141.15
Old 09-13-2010, 01:57 AM
redbird1's Avatar
Los Angeles Ca.
 
Join Date: Feb 2010
Location: Los Angeles
Posts: 92
Rep Power: 14
redbird1 is on a distinguished road
Garage
Connect a volt meter too the cvr.
It should be putting out 5 volts.
If it isn't it's defective.
I bought a brake light switch from them that was defective.
Just cuz it's new doesn't mean it perfect.
Bob.
__________________
Plan your work, and work your plan
http://public.fotki.com/redmk4convt/
http://www.cardomain.com/id/lincmk4
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -4. The time now is 05:26 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.3.0
Garage vBulletin Plugins by Drive Thru Online, Inc.